Trusty Tahr, Finally!!

I migrated from Ubuntu 13.04 to 13.10 with ease. No worries. But the upgradation from 13.10 to 14.04LTS was, really ‘saucy’.

Many of you might be facing the following issue on rebooting once upgraded to 14.04LTS, if you were using WUBI earlier.

“Serious errors were found while checking the disk for /”

Fret now, I present to you the ultimate solution to this problem. After much searching and trying various stuff. (Hero being this post: https://answers.launchpad.net/ubuntu/+question/247265 )

  • Start your computer.
  • You should be able to see at least two options, Ubuntu and Windows. Select Ubuntu and enter GNU GRUB2 menu.(purple color screen in some)
  • Press the key ‘e’ on your keyboard.
  • Replace ro with rw. The lines would be somewhat like this: ro rootflags= sync and should appear like this: rw rootflags= sync
  • Press F10 or ctrl-x to continue.
  • Voila! Your Ubuntu 14.04LTS should be running! But please mind this only a temporary solution. Lets make it permenant. Proceed.
  • Open terminal. (Ctrl+Alt+T)
  • Punch in: sudo vi /etc/grub.d/10_lupin OR sudo gedit /etc/grub.d/10_lupin OR just replace vi with a suitable editor of your choice.
  • Change ro to rw in the following line:
    linux ${rel_dirname}/${basename} root=${LINUX_HOST_DEVICE} loop=${loop_file_relative} ro ${args}

  • And then, just regenerate the GRUB2 boot entry using the following command:
    sudo update-grub

Hope this solves!

**Patience & Perseverence**

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s